Ale.js

安装

兼容性

Ale 不支持 IE8 及以下版本,因为 Ale 使用了 IE8 无法模拟的 ECMAScript 5 特性。但它支持所有兼容 ECMAScript 5 的浏览器。

更新日志

最新稳定版本:1.2.0

每个版本的更新日志见 GitHub

直接用 <script> 引入

直接下载并用 <script> 标签引入,Ale 会被注册为一个全局变量。

不要在生产版本下使用未经压缩的 ale.js 文件,否则这会降低你的文件加载速度!

我们强烈推荐你使用码云 (Gitee) 下载: 【你也可以 切换至GITHUB



CDN

我们推荐链接到一个你可以手动更新的指定版本号:

1
<script src="https://cdn.jsdelivr.net/npm/alejs@1.2.0/ale.js"></script>

请确认了解不同构建版本并在你发布的站点中使用生产环境版本,把 ale.js 换成 ale.min.js

NPM

在用 Ale 构建大型应用时推荐使用 NPM 安装,因为 NPM 能很好地和诸如 webpack 或 browserify 这种的模块打包器配合使用。

1
2
# 最新稳定版
$ npm i alejs

找到了一些错误?在Github上编辑!